Increased event delivery latency

Incident Report for Disruptive Technologies

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 07:49 CEST

Monitoring

Latency has returned to normal as of 04:00 UTC.
Posted Apr 07, 2026 - 06:10 CEST

Investigating

We are currently investigating an issue causing increased latency in delivering events to data connectors and the API, starting around 03:30 UTC.
Posted Apr 07, 2026 - 05:58 CEST
This incident affected: Data ingestion.