Billing pages in Studio
Incident Report for Disruptive Technologies
Resolved
This incident has been resolved.
Posted Apr 05, 2024 - 09:36 CEST
Investigating
Our Billing pages are down at the moment. We are investigating the issue
Posted Apr 05, 2024 - 09:23 CEST
This incident affected: Studio and API.